Need help How To Install And Set-Up The LAMP Stack?

Dan-Kode

Well-Known Coder
May 24, 2019
433
119
53
github.com
Hey there.

I've recently switched my Computer over to GNU/Linux Mint. And so, if I want to do any sort of PHP or Database work(Mainly for WebWareBox), I need to set-up the LAMP Stack. But the thing is, I've looked for tutorials and I can't seem to find any good one. Either that or I'm not trying hard enough.

If you could help with setting-up LAMP then that would be great. If you can find a good tutorial then I'd appreciate it.

Thanks.
 

eeflores

Coder
Jun 26, 2019
32
14
8
One of the things you may want to look into is running a LAMP stack within a docker container. I haven't tried this yet and I did some searching for Docker LAMP solutions and there's a few out there, but this one looks well presented enough: http://devilbox.org/ . It should allow you to develop a web application that isn't using system packages eg. Apache or MySQL.
 

eeflores

Coder
Jun 26, 2019
32
14
8
Actually, if I get a chance sometime this weekend, I'll clone the WebWareBox repo and go through the process of getting it set up in a docker environment. I'll let you know how that goes. I'll be using Ubuntu 19.04, but hopefully you'll be able to do similar instructions for linux Mint.
 

Dan-Kode

Well-Known Coder
May 24, 2019
433
119
53
github.com
@eeflores, I have heard of Docker but I know absolutely nothing about it. I preferably would just like to use Packages for the Server. Besides, it's just to test Code on, not an actual Server that will be hosting a Website.
 

eeflores

Coder
Jun 26, 2019
32
14
8
XAMPP is available for linux, but I haven't tried that.
This is also an excuse for me to do something in Docker and experiment with it. I still plan to try this for myself anyway, but if you really don't want to know I guess just reply to this. I'm hoping to do a decent write-up.
 

eeflores

Coder
Jun 26, 2019
32
14
8
Are you having any issues installing apache/nginx, mysql/mariadb and PHP packages?
 

Dan-Kode

Well-Known Coder
May 24, 2019
433
119
53
github.com
XAMPP is available for linux, but I haven't tried that.
Yeah, I am aware that XAMPP is available but I haven't tried it yet either,
Are you having any issues installing apache/nginx, mysql/mariadb and PHP packages?
Well, I did manage to get Apache2 installed and have it running on localhost. It's only when it came to PHP that things like index.php wouldn't run or display anything. But having PHP Info run would work for some reason yet nothing else did. I have deleted Apache2 and PHP for the time being until I can get an Answer that may help me.
 

Dan-Kode

Well-Known Coder
May 24, 2019
433
119
53
github.com
Well, I have re-installed PHP 7 and Apache2. The only problem is that Apache is not executing any of the PHP code. The only thing Apache will execute is phpinfo(); and that's it. Nothing else will run. Not even an index.php File.

Any help with running PHP on Apache2 would be appreciated.
 

Dan-Kode

Well-Known Coder
May 24, 2019
433
119
53
github.com
Hey, good news.

Everything is actually working now. It was due to a file not existing in the Directory which in return, stopped the Page from rendering. So, I just need to incorporate the rest of the Files and then I can continue Development.
 
  • Like
Reactions: eeflores

eeflores

Coder
Jun 26, 2019
32
14
8
Hey, good news.

Everything is actually working now. It was due to a file not existing in the Directory which in return, stopped the Page from rendering. So, I just need to incorporate the rest of the Files and then I can continue Development.
What file was missing?
 

Dan-Kode

Well-Known Coder
May 24, 2019
433
119
53
github.com
What file was missing?
Well, the index.php File(And if I'm correct, every other File), all require this important File which is settings.php. This File holds important stuff for the Site to function properly or to save time writing stuff(E.g. The Version Number which is displayed at the bottom or the Names of each Page and their URLs). I think that since index.php being linked to settings.php, not to mention how important it is, was stopping it from working.

But anyways, all Pages work properly now.