• Guest, before posting your code please take these rules into consideration:
    • It is required to use our BBCode feature to display your code. While within the editor click < / > or >_ and place your code within the BB Code prompt. This helps others with finding a solution by making it easier to read and easier to copy.
    • Don't share a wall of code. All we want is the problem area, the code related to your issue.


    To learn more about how to use our BBCode feature, please click here.

    Thank you, Code Forum.

Missing com class or dll

Gussy81

New Coder
Hi,

I have an application that was written maybe 10 years ago. Runs fine on a xp machine. When I install it on windows 10 it runs but get the following error: retrieving the com class factory for component with clsid failed due to following error: 80040154 class not registered.

The application was written in VB.

I installed older .net versions in a hope it would help but did not. Would I be missing a DLL file and if so is there a way to find out which one I need to register?

Thanks
Fergus
 
Solution
Hi,

I have an application that was written maybe 10 years ago. Runs fine on a xp machine. When I install it on windows 10 it runs but get the following error: retrieving the com class factory for component with clsid failed due to following error: 80040154 class not registered.

The application was written in VB.

I installed older .net versions in a hope it would help but did not. Would I be missing a DLL file and if so is there a way to find out which one I need to register?

Thanks
Fergus
I figured it out. I needed crystal reports installed. Thanks

Gussy81

New Coder
Hi,

I have an application that was written maybe 10 years ago. Runs fine on a xp machine. When I install it on windows 10 it runs but get the following error: retrieving the com class factory for component with clsid failed due to following error: 80040154 class not registered.

The application was written in VB.

I installed older .net versions in a hope it would help but did not. Would I be missing a DLL file and if so is there a way to find out which one I need to register?

Thanks
Fergus
I figured it out. I needed crystal reports installed. Thanks
 
Solution
Top